Quantcast

Can't Connect to Database (CakePHP 1.3 -> 2.1.3 Migration)

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Can't Connect to Database (CakePHP 1.3 -> 2.1.3 Migration)

Miles G
Hi, I'm trying to figure out what possible problem could be causing me not to connect to my db on the 2.1.3 version. I connect just fine on the 1.3 version and the only big changes I notice in the database.php file is the difference of 'host' => 'mssql' in the 1.3 version compared to 'datasource' => in the 2.1.3 version. Here is a pastie.org link to get more info and see what happens for me as well as my database.php file for the different versions.

http://pastie.org/4154510

Just to clarify, the new version was a fresh download where the only changes I made were the hashing security part in the core file and then modifying database.php. The database is on a separate computer using Microsoft SQL Server 2003 (on Windows 2003) and the OS where the project is stored is also on another computer with Windows 2003. There are 0 problems with connecting to the database on the 1.3 version just to say one more time!

Let me know if you see something that could be causing this or if you need more information !

Thanks,

Miles

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't Connect to Database (CakePHP 1.3 -> 2.1.3 Migration)

lowpass
You have the port value as a string. Try removing the quotes.

On Wed, Jun 27, 2012 at 10:23 AM, Miles G <[hidden email]> wrote:

> Hi, I'm trying to figure out what possible problem could be causing me not
> to connect to my db on the 2.1.3 version. I connect just fine on the 1.3
> version and the only big changes I notice in the database.php file is the
> difference of 'host' => 'mssql' in the 1.3 version compared to 'datasource'
> => in the 2.1.3 version. Here is a pastie.org link to get more info and see
> what happens for me as well as my database.php file for the different
> versions.
>
> http://pastie.org/4154510
>
> Just to clarify, the new version was a fresh download where the only changes
> I made were the hashing security part in the core file and then modifying
> database.php. The database is on a separate computer using Microsoft SQL
> Server 2003 (on Windows 2003) and the OS where the project is stored is also
> on another computer with Windows 2003. There are 0 problems with connecting
> to the database on the 1.3 version just to say one more time!
>
> Let me know if you see something that could be causing this or if you need
> more information !
>
> Thanks,
>
> Miles
>
> --
> Our newest site for the community: CakePHP Video Tutorials
> http://tv.cakephp.org
> Check out the new CakePHP Questions site http://ask.cakephp.org and help
> others with their CakePHP related questions.
>
>
> To unsubscribe from this group, send email to
> [hidden email] For more options, visit this group at
> http://groups.google.com/group/cake-php

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org 
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.


To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't Connect to Database (CakePHP 1.3 -> 2.1.3 Migration)

Miles G
Thanks for pointing that out cricket; however, I am still getting the same error message after fixing that.

On Wednesday, June 27, 2012 11:15:16 AM UTC-5, cricket wrote:
You have the port value as a string. Try removing the quotes.

On Wed, Jun 27, 2012 at 10:23 AM, Miles G <[hidden email]> wrote:

> Hi, I'm trying to figure out what possible problem could be causing me not
> to connect to my db on the 2.1.3 version. I connect just fine on the 1.3
> version and the only big changes I notice in the database.php file is the
> difference of 'host' => 'mssql' in the 1.3 version compared to 'datasource'
> => in the 2.1.3 version. Here is a pastie.org link to get more info and see
> what happens for me as well as my database.php file for the different
> versions.
>
> http://pastie.org/4154510
>
> Just to clarify, the new version was a fresh download where the only changes
> I made were the hashing security part in the core file and then modifying
> database.php. The database is on a separate computer using Microsoft SQL
> Server 2003 (on Windows 2003) and the OS where the project is stored is also
> on another computer with Windows 2003. There are 0 problems with connecting
> to the database on the 1.3 version just to say one more time!
>
> Let me know if you see something that could be causing this or if you need
> more information !
>
> Thanks,
>
> Miles
>
> --
> Our newest site for the community: CakePHP Video Tutorials
> http://tv.cakephp.org
> Check out the new CakePHP Questions site http://ask.cakephp.org and help
> others with their CakePHP related questions.
>
>
> To unsubscribe from this group, send email to
> [hidden email] For more options, visit this group at
> http://groups.google.com/group/cake-php

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't Connect to Database (CakePHP 1.3 -> 2.1.3 Migration)

Paul Willis
Hi

I would suggest that your version of Microsoft SQL Server is too old. From the database.php default files...


1.3.15
 * mssql - Microsoft SQL Server 2000 and higher,

2.1.3
 * Database/Sqlserver - Microsoft SQL Server 2005 and higher


Cheers

Paul

On 27 Jun 2012, at 19:26, Miles G wrote:

Thanks for pointing that out cricket; however, I am still getting the same error message after fixing that.

On Wednesday, June 27, 2012 11:15:16 AM UTC-5, cricket wrote:
You have the port value as a string. Try removing the quotes.

On Wed, Jun 27, 2012 at 10:23 AM, Miles G <[hidden email]> wrote:

> Hi, I'm trying to figure out what possible problem could be causing me not
> to connect to my db on the 2.1.3 version. I connect just fine on the 1.3
> version and the only big changes I notice in the database.php file is the
> difference of 'host' => 'mssql' in the 1.3 version compared to 'datasource'
> => in the 2.1.3 version. Here is a pastie.org link to get more info and see
> what happens for me as well as my database.php file for the different
> versions.
>
> http://pastie.org/4154510
>
> Just to clarify, the new version was a fresh download where the only changes
> I made were the hashing security part in the core file and then modifying
> database.php. The database is on a separate computer using Microsoft SQL
> Server 2003 (on Windows 2003) and the OS where the project is stored is also
> on another computer with Windows 2003. There are 0 problems with connecting
> to the database on the 1.3 version just to say one more time!
>
> Let me know if you see something that could be causing this or if you need
> more information !
>
> Thanks,
>
> Miles
>
> --
> Our newest site for the community: CakePHP Video Tutorials
> http://tv.cakephp.org
> Check out the new CakePHP Questions site http://ask.cakephp.org and help
> others with their CakePHP related questions.
>
>
> To unsubscribe from this group, send email to
> [hidden email] For more options, visit this group at
> http://groups.google.com/group/cake-php

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't Connect to Database (CakePHP 1.3 -> 2.1.3 Migration)

Miles G
My Microsoft SQL server is currently the 2005 version, but then again I wouldn't be surprised if that's too old as well?

On Thursday, June 28, 2012 4:35:01 AM UTC-5, PaulW wrote:
Hi

I would suggest that your version of Microsoft SQL Server is too old. From the database.php default files...


1.3.15
 * mssql - Microsoft SQL Server 2000 and higher,

2.1.3
 * Database/Sqlserver - Microsoft SQL Server 2005 and higher


Cheers

Paul

On 27 Jun 2012, at 19:26, Miles G wrote:

Thanks for pointing that out cricket; however, I am still getting the same error message after fixing that.

On Wednesday, June 27, 2012 11:15:16 AM UTC-5, cricket wrote:
You have the port value as a string. Try removing the quotes.

On Wed, Jun 27, 2012 at 10:23 AM, Miles G <[hidden email]> wrote:

> Hi, I'm trying to figure out what possible problem could be causing me not
> to connect to my db on the 2.1.3 version. I connect just fine on the 1.3
> version and the only big changes I notice in the database.php file is the
> difference of 'host' => 'mssql' in the 1.3 version compared to 'datasource'
> => in the 2.1.3 version. Here is a pastie.org link to get more info and see
> what happens for me as well as my database.php file for the different
> versions.
>
> http://pastie.org/4154510
>
> Just to clarify, the new version was a fresh download where the only changes
> I made were the hashing security part in the core file and then modifying
> database.php. The database is on a separate computer using Microsoft SQL
> Server 2003 (on Windows 2003) and the OS where the project is stored is also
> on another computer with Windows 2003. There are 0 problems with connecting
> to the database on the 1.3 version just to say one more time!
>
> Let me know if you see something that could be causing this or if you need
> more information !
>
> Thanks,
>
> Miles
>
> --
> Our newest site for the community: CakePHP Video Tutorials
> http://tv.cakephp.org
> Check out the new CakePHP Questions site http://ask.cakephp.org and help
> others with their CakePHP related questions.
>
>
> To unsubscribe from this group, send email to
> [hidden email] For more options, visit this group at
> http://groups.google.com/group/cake-php

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't Connect to Database (CakePHP 1.3 -> 2.1.3 Migration)

Paul Willis
Okay, just you said earlier "The database is on a separate computer using Microsoft SQL Server 2003 (on Windows 2003)"


On 28 Jun 2012, at 15:08, Miles G wrote:

My Microsoft SQL server is currently the 2005 version, but then again I wouldn't be surprised if that's too old as well?

On Thursday, June 28, 2012 4:35:01 AM UTC-5, PaulW wrote:
Hi

I would suggest that your version of Microsoft SQL Server is too old. From the database.php default files...


1.3.15
 * mssql - Microsoft SQL Server 2000 and higher,

2.1.3
 * Database/Sqlserver - Microsoft SQL Server 2005 and higher


Cheers

Paul

On 27 Jun 2012, at 19:26, Miles G wrote:

Thanks for pointing that out cricket; however, I am still getting the same error message after fixing that.

On Wednesday, June 27, 2012 11:15:16 AM UTC-5, cricket wrote:
You have the port value as a string. Try removing the quotes.

On Wed, Jun 27, 2012 at 10:23 AM, Miles G <[hidden email]> wrote:

> Hi, I'm trying to figure out what possible problem could be causing me not
> to connect to my db on the 2.1.3 version. I connect just fine on the 1.3
> version and the only big changes I notice in the database.php file is the
> difference of 'host' => 'mssql' in the 1.3 version compared to 'datasource'
> => in the 2.1.3 version. Here is a pastie.org link to get more info and see
> what happens for me as well as my database.php file for the different
> versions.
>
> http://pastie.org/4154510
>
> Just to clarify, the new version was a fresh download where the only changes
> I made were the hashing security part in the core file and then modifying
> database.php. The database is on a separate computer using Microsoft SQL
> Server 2003 (on Windows 2003) and the OS where the project is stored is also
> on another computer with Windows 2003. There are 0 problems with connecting
> to the database on the 1.3 version just to say one more time!
>
> Let me know if you see something that could be causing this or if you need
> more information !
>
> Thanks,
>
> Miles
>
> --
> Our newest site for the community: CakePHP Video Tutorials
> http://tv.cakephp.org
> Check out the new CakePHP Questions site http://ask.cakephp.org and help
> others with their CakePHP related questions.
>
>
> To unsubscribe from this group, send email to
> [hidden email] For more options, visit this group at
> http://groups.google.com/group/cake-php

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php


--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't Connect to Database (CakePHP 1.3 -> 2.1.3 Migration)

Miles G
Sorry about that, I mixed that up the OS is Windows 2003 and I thought the Microsoft SQL server was 2003, but I just looked and it's 2005.

On Thursday, June 28, 2012 9:16:51 AM UTC-5, PaulW wrote:
Okay, just you said earlier "The database is on a separate computer using Microsoft SQL Server 2003 (on Windows 2003)"


On 28 Jun 2012, at 15:08, Miles G wrote:

My Microsoft SQL server is currently the 2005 version, but then again I wouldn't be surprised if that's too old as well?

On Thursday, June 28, 2012 4:35:01 AM UTC-5, PaulW wrote:
Hi

I would suggest that your version of Microsoft SQL Server is too old. From the database.php default files...


1.3.15
 * mssql - Microsoft SQL Server 2000 and higher,

2.1.3
 * Database/Sqlserver - Microsoft SQL Server 2005 and higher


Cheers

Paul

On 27 Jun 2012, at 19:26, Miles G wrote:

Thanks for pointing that out cricket; however, I am still getting the same error message after fixing that.

On Wednesday, June 27, 2012 11:15:16 AM UTC-5, cricket wrote:
You have the port value as a string. Try removing the quotes.

On Wed, Jun 27, 2012 at 10:23 AM, Miles G <[hidden email]> wrote:

> Hi, I'm trying to figure out what possible problem could be causing me not
> to connect to my db on the 2.1.3 version. I connect just fine on the 1.3
> version and the only big changes I notice in the database.php file is the
> difference of 'host' => 'mssql' in the 1.3 version compared to 'datasource'
> => in the 2.1.3 version. Here is a pastie.org link to get more info and see
> what happens for me as well as my database.php file for the different
> versions.
>
> http://pastie.org/4154510
>
> Just to clarify, the new version was a fresh download where the only changes
> I made were the hashing security part in the core file and then modifying
> database.php. The database is on a separate computer using Microsoft SQL
> Server 2003 (on Windows 2003) and the OS where the project is stored is also
> on another computer with Windows 2003. There are 0 problems with connecting
> to the database on the 1.3 version just to say one more time!
>
> Let me know if you see something that could be causing this or if you need
> more information !
>
> Thanks,
>
> Miles
>
> --
> Our newest site for the community: CakePHP Video Tutorials
> http://tv.cakephp.org
> Check out the new CakePHP Questions site http://ask.cakephp.org and help
> others with their CakePHP related questions.
>
>
> To unsubscribe from this group, send email to
> [hidden email] For more options, visit this group at
> http://groups.google.com/group/cake-php

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php


--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't Connect to Database (CakePHP 1.3 -> 2.1.3 Migration)

Miles G
In reply to this post by Miles G
I figured out how to get it connected. I had to download some drivers (http://www.php.net/manual/en/ref.pdo-sqlsrv.php)  for my php directory for it to connect.


--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.
 
 
To unsubscribe from this group, send email to
[hidden email] For more options, visit this group at http://groups.google.com/group/cake-php
Loading...